+(65) 8344 4290 Ciscodumps.net@gmail.com Room 907, Block B, Baoneng Entrepreneurship Center, Guangrong Road, Hongqiao District, Tianjin

ThinkMo EDU Share – network 67.Detailed Explanation of VTP Technology

蒂娜 2 Comments 01/10/2023

ThinkMo EDU Share – network 67.Detailed Explanation of VTP Technology

VTP (VLAN Trunk Protocol) provides a method for managing VLANs on switches. This protocol allows us to create, modify and delete VLANs on one or several central points (Server), and VLAN information is automatically transmitted through the Trunk link. Spread to other switches, any exchange participating in VTP can accept these modifications, and all switches keep the same VLAN information.

VTP is organized into management domains (VTP Domain), and switches in the same domain can share VLAN information. According to the different functions of the switch in the VTP domain, VTP can be divided into the following three modes.

Server mode (Server): VLANs can be created, modified and deleted on the VTP server, and the information will be notified to other switches in the domain at the same time. By default, the switch is in server mode. Each VTP domain must have at least one server, and there can be multiple VTP servers in a domain.

Client mode (Llient): The VTP client is not allowed to create, modify and delete VLANs, but it will listen to VTP announcements from other switches and change its own VLAN information. The received VTP information will also be forwarded to other switches on the Trunk link, so this switch can also act as a VTP relay.

Transparent mode (Transparent): Switches in this mode do not participate in VTP. A switch in this mode can create, modify and delete VLANs, but the VLAN information will not be advertised to other switches, nor will it accept VTP notifications from other switches to update its own VLAN information. However, it should be noted that it will forward the received VTP announcement through the Trunk link, thus acting as a VTP relay, so the switch can be regarded as transparent.

VTP notifications are sent in the form of multicast frames. There is a field in the VTP notification called Revision, with an initial value of 0. As long as VLANs are created, modified and deleted on the VTP Server, the Revision of the notification will increase by 1. The notification also includes the change information of the VLAN. It should be noted that notifications with high Revision will cover notifications with low Revision, regardless of whether the sender is Server or Client. The switch only advertises that the Resivison number is higher than the Resivison number stored locally; if the switch receives a notification that is lower than its own Resivison number, it will overwrite it with its own VLAN information in reverse.

Experiment of VTP Technology in Switches

Layer 3 switch SW configuration:

SW#show run

Building configuration…

Current configuration: 1563 bytes

!

version 16.3.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname SW

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet1/0/1

switchport mode trunk

!

interface GigabitEthernet1/0/2

switchport mode trunk

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interfaceVlan1

no ip address

shutdown

!

interfaceVlan10

mac-address 0090.2b80.b901

ip address 192.168.10.254 255.255.255.0

!

interfaceVlan20

mac-address 0090.2b80.b902

ip address 192.168.20.254 255.255.255.0

!

ip classless

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

!

end

SW#

Layer 2 switch SA configuration:

SA#show run

Building configuration…

Current configuration: 1153 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname SA

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 10

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

switchport access vlan 20

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport mode trunk

!

interface GigabitEthernet0/2

!

interfaceVlan1

no ip address

shutdown

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

!

!

end

SA#

Layer 2 switch SB configuration: same as layer 2 switch SA configuration, skip here .

At this time, go to ping 192.168.10.254, 192.168.20.254, 192.168.20.1, 192.168.20.2 through PC1:192.168.10.1, and find that the 20.1 and 20.2 ip addresses cannot be pinged. Check the Layer 3 switch configuration and find that the routing function is not enabled.

Enter the layer-3 routing and enable the routing function.

Tested again and found that all pings passed.

ThinkMo CCNA Dump exam information exchange group:

CCNA/CCNP/CCIE telegram study group:https://t.me/ccie_ei_lab
CCNA/CCNP/CCIE dump:
WAHTAPP:+65 83444290
WAHTAPP:+63 9750724648

ThinkMo CCNA 200-301 Tutorial VIP Exclusive:
https://www.youtube.com/playlist?list=PLIq0cWorv-oyWHaoH79460mAa3-4AWpvw

The complete EVE_NG file, free learning PDF and PPT that can be used directly, as well as video explaining the technical points are all here!

2 Comments

Leave a Reply

X