+(65) 8344 4290 Ciscodumps.net@gmail.com Room 907, Block B, Baoneng Entrepreneurship Center, Guangrong Road, Hongqiao District, Tianjin

ThinkMo EDU Share – network 66.RIP triggered update

蒂娜 1 Comment 01/09/2023

ThinkMo EDU Share – network 66.RIP triggered update

Today I will teach you how to complete RIP and trigger updates . Since both RIP ver 1 and ver 2 will regularly send the routing table to the network every 30 seconds, but usually, the bandwidth of the WAN link is relatively low, and the bandwidth is precious, in order to better utilize and save the WAN bandwidth, RIP can be adjusted to suppress the sending of routing updates on the WAN link, and only send the changed routing when the routing changes. This is the triggering update mechanism of RIP, and it is based on the interface opening or closed.

Because RIP was developed in the early days of the network, in the early days, the wide area network was a serial link, or a point-to-point link, so RIP trigger update can only be turned on or off on a point-to-point link. For Frame-Relay In multi-access interfaces such as Ethernet, RIP trigger update is not supported, but the Frame-Relay point-to-point sub-interface is considered by RIP as a point-to-point link, and trigger update can be enabled.

Because the route of RIP will be updated every 30 seconds, if the route in the routing table has not received an update for more than 180 seconds, it will be marked as unavailable, and if it has not received an update for 240 consecutive seconds, it will be deleted from the routing table , so when a RIP router starts triggering updates, it will no longer send routing updates to the peer if the route has not changed. This will inevitably cause the peer router to delete the received route from the routing table after 240 seconds. Delete, in order to prevent such problems,

the update mechanism triggered by RIP needs to be enabled on both routers, otherwise it will not take effect. After both parties are enabled, the routes received by each other will be marked as permanent and do not need to receive updates again.

Note: RIP triggered update supports ver 1 and ver 2.

Test RIP trigger update

1. Configure the basic network environment

(1) Configure R1:

r1(config)#int serial 1/0

r1(config-if)#encapsulation frame-relay

r1(config-if)#no frame-relay inverse-arp

r1(config -if)#no arp frame-relay

r1(config-if)#no ip address

r1(config-if)#no shutdown

r1(config)#int serial 1/0.12 point-to-point

r1(config-subif)# ip address 12.1.1.1 255.255.255.0

r1(config-subif)#frame-relay interface-dlci 102

r1(config)#int loopback 10

r1(config-if)#ip add 10.1.1.1 255.255.255.0

r1(config)# router rip

r1(config-router)#network 12.0.0.0

r1(config-router)#network 10.0.0.0

Description: Configure network segments 12.1.1.0 and 10.1.1.0 on R1, because R1 and R2 are connected through Frame-Felay, In Frame-Felay, only point-to-point sub-interfaces are considered point-to-point links.

(2) Configure R2:

r2(config)#int serial 1/0

r2(config-if)#en frame-relay

r2(config-if)#no frame-relay inverse-arp

r2(config-if)#no arp frame-relay

r2(config-if)#no ip address

r2(config-if)#no shutdown

r2(config)#int serial 1/0.12 point-to-point

r2(config-subif)#ip address 12.1.1.2 255.255 .255.0

r2(config-subif)#frame-relay interface-dlci 201

r2(config)#int loopback 20

r2(config-if)#ip address 20.1.1.1 255.255.255.0

r2(config)#router rip

r2(config- router)#network 12.0.0.0

r2(config-router)#network 20.0.0.0

Description: Configure network segments 12.1.1.0 and 20.1.1.0 on R2 and put them into the RIP process.

2. Test RIP trigger update

(1) View the current routing table situation of R1 and R2:

r1#sh ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2

i – IS-IS, su – IS -IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2

ia – IS-IS inter area, * – candidate default, U – per-user static route

o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

R 20.0.0.0/8 [120/1] via 12.1.1.2, 00:00:15, Serial1/0.12

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.1.0 is directly connected , Loopback10

12.0.0.0/24 is subnetted, 1 subnets

C 12.1.1.0 is directly connected, Serial1/0.12

r1#

r2#sh ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2

i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2

ia – IS-IS inter area, * – candidate default, U – per-user static route

o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/24 is subnetted, 1 subnets

C 20.1.1.0 is directly connected, Loopback20

R 10.0.0.0/8 [120/1] via 12.1. 1.1, 00:00:11, Serial1/0.12

12.0.0.0/24 is subnetted, 1 subnets

C 12.1.1.0 is directly connected, Serial1/0.12

r2#

Explanation: The current routing table of R1 and R2 is normal, and both can successfully receive each other Incoming route.

(2) Enable RIP trigger update on the R1 interface:

r1(config)#int serial 1/0.12

r1(config-subif)#ip rip triggered

Note: successfully inputting the RIP trigger update command on the interface does not mean RIP trigger The update is already in effect.

ThinkMo CCNA Dump exam information exchange group:

CCNA/CCNP/CCIE telegram study group:https://t.me/ccie_ei_lab
CCNA/CCNP/CCIE dump:
WAHTAPP:+65 83444290
WAHTAPP:+63 9750724648

ThinkMo CCNA 200-301 Tutorial VIP Exclusive:
https://www.youtube.com/playlist?list=PLIq0cWorv-oyWHaoH79460mAa3-4AWpvw

The complete EVE_NG file, free learning PDF and PPT that can be used directly, as well as video explaining the technical points are all here!

1 Comment

Leave a Reply

X